---------------------------------------------------------------------------------------------------------------------------------------------------------CREATION OF DIGITAL FABRICS
---------------------------------------------------------------------------------------------------------------------------------------------------------Costume illustrations can be customized by adding images of the actual fabric that will be used to make
the garment. Fabric images, or textures, can be found on the internet, or can be made from actual
fabrics. In this guide, we will demonstrate how to create and save digital fabric images. In our next
guide, Working with Digital Fabrics, we will show how to integrate the digital fabrics into the
costume illustration.

This is part of an antique kimono that we scanned to use as a background image on our website.

WHERE TO GET THE FABRIC IMAGE:
Option 1

– Internet:
There are web links that provide pattern images for everyone to use. Try searching under the
keywords “fabric textures”.
Limitations of internet sources:
1- It is not always possible to find the exact fabric you wish to have despite the amount
of images that the internet provides.
2- There is a scarcity of good quality high-resolution pattern images, particularly for free usage.
The quality of many currently available fabric images is often inadequate if you are
planning on printing your final costume design. Internet images are often at a resolution that
will look alright on screen, but will be overly pixilated when printed.

Option 2

- Scan your own fabric:
1- This will give the exact fabric that you wish, and will give total control over image quality.
2- It’s often quicker to scan your own fabric than to search through sites.
3- By using your own fabric, you can compile a collection of ready to use virtual fabrics.

 Refer to How to Scan a Fabric guide.

IMPORT THE FABRIC PATTERN IN PHOTOSHOP:
Step 1

- Once you have scanned a fabric or downloaded a fabric image from the internet, you are ready to
begin. Go to the Menu bar: File > Open

Step 2

- In the Open window: Find the pattern file that you wish to use on your computer > Click on the
file to select it > click Open.
 Your file will appear automatically in your main Photoshop workspace.

Before moving to the next step, let’s talk about what Resolution means and why it is important when
working on Photoshop. Files that are intended for print require a different resolution than files meant for
screen viewing only.
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If you already know about the resolution of images you can skip to the next step to learn how to check
your file’s resolution on Photoshop.
What is Resolution?
The resolution is measured in Dpi (Dots per Inch). The dots are also called pixels. By measuring the
resolution of an image you’ll be able to know how many Dots (or pixels) can be placed within an inch of
that image. Digital images are constructed by accumulating and gathering dots. If you don’t have enough
dots to “build” your image, you’ll have “gaps” within it. This is what we call a pixilated image.

You’ve probably seen the pixilated effect when attempting to magnify an image. Increasing the size of an
image means reconstructing it on a bigger space, which in turn means you will need more dots for it. If
your image is a low resolution image to begin with, that means it only has the bare minimum number of
pixels needed. When attempting to make the image bigger you won’t have enough dots to reconstruct it,
leading to a pixilated image.
Three important points concerning the resolution:
One: The resolution you need for a particular image depends on where you plan to view it. An
image needs less “Dots” to be constructed on a screen than on paper. The general standard
numbers are: 72 Dpi for web images and 300Dpi for images meant to be printed.
Two: You can always decrease but NEVER increase your resolution. In other words if you originally
have a 72 Dpi file, changing its resolution to 300 Dpi only means you increased your image’s
dot capacity but not the actual number of dots themselves. Photoshop, or any other
program, doesn’t create dots for you. If you don’t have them from the beginning you won’t
be able to produce them.
Of course the other way around is possible: if you have a large file of 300 Dpi you can
lower its resolution to 72Dpi. This will lead to decreasing the dot capacity as well as the
number of dots in your image to the bare minimum. Usually this is done to lower the size of
an image for ease of e-mailing or downloading.
Third: The higher the resolution, the heavier your file will be. Having a smaller size is useful for faster
online web display or email attachment. If you’re sending an image only meant to be viewed
on screen, 72 Dpi is sufficient. Lowering the resolution will help you decrease the size of your
file by few hundreds and even thousands of Megabytes, which makes it much easier to
download.
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How to check the resolution of a file:
Step 3

- Go to the Menu bar: Image > Image Size
 A small window will open.

Step 4

-In the Image Size window: make sure that Pixel/Inch is selected in the small drop down menu
to the right of Resolution

Step 5

-The number written next to Resolution is the resolution of your image.

When you check your file’s resolution, one of the three following cases will most likely be presented to
you:
- Case1: your image is 72 Dpi, most common with images found on the internet. If that’s the case this
image is only useful when viewed on screen. If you’re planning on printing your design, a 72 Dpi image is
useless to you.
- Case 2: your image is 300Dpi. This is a perfect resolution to work with, because in most design cases
you will need to print your design at some point, so it’s essential to work with a 300 Dpi file.
- Case 3: Any number between the last two. You might find a 96, 180, ~230 or ~260 resolutions, among
others. In most cases any resolution below 180 renders the pattern image unusable, anything higher will
depend on your Photoshop skills and the complexity of your pattern.
Very important:
At a later point in the process you will adjust the resolution of your pattern to 300 Dpi, so the closer the
initial resolution is to 300, the better and easier your work will be.
CROP YOUR PATTERN:
When you open a new image of a pattern on Photoshop, the first things you need to do:
1- Decide which part you wish to use.
2- Make sure your pattern’s image is a square. This isn’t essential but a square shaped pattern is the
standard shape widely used, and it will help you make your work easier and more efficient in
subsequent steps.

Step 1

- In the Toolbar: Select Crop Tool

 The Crop tool allows you to select a particular area of your image and get rid of whatever remains around it.

The darker area outside the Crop
frame represents the part that will
be “cropped out” or removed from
your image once done.
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Step 2

- On your keyboard: Hold down the Shift Key
 Holding down the Shift key while cropping will allow you to have a perfectly square shaped crop.

Step 3

–Start cropping your image by creating a frame around the part of your pattern that you wish
to keep.
How: Click and hold down your cursor on the top left side of the part that you wish to keep, then
drag it toward the bottom right corner > Unclick then let go of the Shift Key of your keyboard.
 After you unclick, the area outside of your crop will become darker to indicate which part will be removed.
 A Scaling Frame with eight different anchor points will appear around the part you selected. These anchor

points will allow you to resize your square.

Step 4

-If you’re satisfied with the selection, Click enter on your Keyboard. If not, move to Step 5, before
pressing enter, to learn how to move your Scaling frame or adjust its size.

Step 5

-To change the placement of your Scaling frame, place your cursor inside the frame, then click and
drag it around until you’re satisfied with its placement
-To adjust the size of your frame: Hold down the Shift Key on your keyboard again, then click and
drag any of the four corner anchor points:
1- To make it bigger, drag the corner anchor point toward the outside of the frame.
2- To make it smaller drag it toward the inside.

Step 6

- When satisfied Press Enter
 After pressing Enter, everything outside of the Scaling Frame will be removed, leaving only what you

have selected.

Step 7

- Go to the Menu bar: Image > Image Size
 A small window will open.

Step 8

-In the Image Size window, adjust the following features in the same order indicated:
1- Resolution should be preferably at 300 Pixel/inch
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2- At the bottom of the window: Constrain proportions should be checked.
3- At the top of the window, under Pixel dimension: set the Width and Length to 512 pixels
Step 9

-Press Ok

Important: It is at that point where you can see if the pixilated effect isn’t too damaging to your
pattern and if it is easy to fix. It all depends on the complexity of your pattern and your Photoshop
cleaning skills. If the change in resolution damaged your pattern too much you may have to find a
better quality image.
SEAMLESS OR NOT:
At this point you should have a high resolution, square shaped pattern. The next thing you need to do
is make sure your pattern is seamless. When your fabric is seamless, it means that your fabric will
appear as though the amount is limitless in all directions.
Step 1

- Go to the Menu bar: Filter > Other > Offset
 the Offset window will open.

Step 2

- In the Offset window:
1- Make sure Wrap around at the bottom is checked off.
2- On the top of the window: Set the Horizontal and Vertical to half of your image’s actual
width and length. In our case both are 512, so write 256 next to each one.

You can see the effect of the Offset filter on your image before clicking Ok. If the image appears to be
divided into four parts (you will see a distinguishable vertical or horizontal line or both), that means
your pattern is not seamless. If your image looks perfectly homogeneous, then your pattern is perfectly
seamless. If this is the case then skip the next parts and move to the “SAVE YOUR PATTERN” section.
Step 3

-Press Ok

Understanding Offset:
When a pattern is called seamless, it means the pattern could be repeated indefinitely (horizontally or
vertically) without showing any dividing lines between one “copy” and the next. In other words, its right
side should be perfectly continuous with its left side (for horizontal repetition) and its bottom side
should be continuous with its top one (for vertical repetition).
One obvious way to know if that’s the case is to create several copies of the original pattern and then
position them manually next to each other in all directions to see if any division lines will appear.
The Offset filter offers a second more practical way to determine if your pattern is seamless. It divides
the original pattern image into four parts and repositions these parts in a way that makes their outside
borders (top, bottom, left and right) meet within the pattern itself allowing us to compare right away.
The illustration bellow will help you see visually what happens when you “offset” a pattern:

Creation of Digital Fabrics Guide: 5 of 9
--------------------------------------------© Catherine Bradley 2015

Below you can see an example of how a pattern that is not seamless looks after applying the Offset filter.

If your pattern turns out to be non-seamless, it means you will need to “repair” it.
MAKING THE PATTERN SEAMLESS:
The Clone Stamp Tool is used to repair the offset joint lines.
What is the Clone Stamp Tool?
The Clone Stamp tool allows you to sample an image, which means to copy a part of that image, and
then use that particular sample to paint a patch at any other place in the image. In the particular
“pattern repair” situation this tool will allow you to get rid of the demarcation lines by painting over
them with samples taken from similar areas surrounding the line.
Most often you will need to work on small and specific areas within your image so it’s essential to know
how to zoom in and out on Photoshop. Zooming in on area will allow you to have a cleaner and more
precise result at the end so before going any further, refer to Tips for beginners guide if need to learn
more about zooming in and out.
How to use the Clone Stamp Tool:
Step 1

-Go to the Toolbar: Select the Clone Stamp Tool

.

Step 2

-On your keyboard: Press Down the Alt Key and then click on the area of the image that you
wish to clone (or sample).

Step 3

-Go to the part of your image where you want to apply the cloning (for example the
demarcation lines), then paint over it by clicking several times over that part, or by clicking
and dragging as with a paint brush.

For more effective use of the Clone Stamp tool, especially when it comes to pattern repairs, you will
often need to adjust three main features throughout your process for a better and smoother work.
These three features are: Hardness, Master diameter and Opacity
Hardness: The hardness indicates the sharpness of a tool’s edge. The higher the hardness of your
Clone Stamp Tool, the more defined its edges will be. This feature is particular useful, because
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decreasing the Hardness of your Clone Stamp tool will allow its edges to blend into the surrounding
area, rather than remaining crisp.
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How to change the hardness of a tool:
Step 1
Step 2

- Go to the Options bar > click on Preset Picker
- Change Hardness to adjust the definition of your tool’s edges.

 Increasing the Hardness will make the edges of your tool more defined.
 See image below to learn how to adjust the Hardness of your tool.

By moving the cursor or changing the
percentage you can change the hardness
of your tool.

Master Diameter:
The master diameter of a tool is its size. Throughout your work you will need to adjust the size of your
tool depending on the area you wish to clone over. It’s better to keep the size of your Clone tool small
to assure the least damage possible to your pattern.
How to adjust the size:
Method One:

- Go to Options bar > click on Preset Picker
Creation of Digital Fabrics Guide: 7 of 9
--------------------------------------------© Catherine Bradley 2015

- Change Master Diameter to adjust the size of your tool.
 See image below to learn more about adjusting the Master Diameter of a tool.

By moving the cursor or changing the
pixels you can change the size (the
width) of your tool.

Method Two:
-On your keyboard: Hold down the “]” key to make the stroke bigger and the “[“key to make it smaller.

-When you’re satisfied with the size of your tool, take your finger off the key.
Opacity:

The Opacity of your tool defines its transparency. Lowering the Opacity renders your cloning more
transparent. Adjusting the opacity of your tool will prove to be extremely helpful, especially when the
difference between the area you’re sampling from and the area you wish to clone to is significant. In
these cases lowering the Hardness alone will not merge the two areas perfectly together; while the
Hardness decreases the intensity of the edges, the Opacity decreases the intensity of the entire
clone. This makes the gradation from one area to another more subtle by adjusting the Opacity instead
of just adjusting the Hardness alone.

How to adjust the opacity:
-Go to the Top bar > Adjust the percentage number next to Opacity

------------------------------------------------------------------------------------------------------------------Very Important:
To achieve the desired effect from the Clone Stamp Tool you may need to adjust the hardness, size and
opacity several times throughout your process, depending on the complexity of the pattern you’re
working on. Multiple passes over the cloning area may be needed to achieve the desired effect.
-------------------------------------------------------------------------------------------------------------------
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SAVING THE PATTERN:
After completing the cloning and cleaning, when you’re completely satisfied with your pattern, you will
need to save it into your Photoshop’s library of patterns. This is essential for you to turn the simple
image of a pattern to an actual seamless pattern that you can use on your costume design.
How to save a pattern:
Step 1

-Go to the Menu Bar: Edit > Define Pattern
 A window will open

Step 2

- In the Pattern Name window: define the name of your new pattern > Press OK
 The pattern is now saved in Photoshop. To know how to use it in your costume design, refer to the
Working with digital fabrics guide.

 Very Important: Make sure you keep your main PSD file of the pattern. Saving it in Photoshop’s library
only allows you to use the pattern but not to actually save it, which means if you loose
your main file you will loose the pattern.

------------------------------------------------------------------------------------------------------------------------------------------------------------FINAL THOUGHTS:
------------------------------------------------------------------------------------------------------------------------------------------------------------Digital textile images have numerous uses, not only in costume illustration, but in all types of visual
design. They can be used as textures by video game designers, surface treatments in package design,
and for visual interest in desktop publishing. The subtlety and wide variety of fabrics can become an
astounding inspiration in any creative process.
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